Deelberekeningen maken voor formules


Omvangrijke formules met meerdere in elkaar geschoven functies zijn lastig te bewerken. De foutcontrole geeft weliswaar een waarschuwing wanneer er een haakje, een leesteken of een aanhalingsteken ontbreekt, en biedt vaak ook suggesties voor de correctie, maar als de formule syntactisch correct, maar inhoudelijk fout is, verschijnt er in de cel niet meer dan een korte, kernachtige foutmelding zoals #GETAL!, #VERW! of #WAARDE!.

Als u gemakkelijker naar fouten wilt kunnen zoeken, zou u eigenlijk een bijzonder nuttige techniek moeten kennen, namelijk het maken van deelberekeningen voor een formule. Het is mogelijk elk afzonderlijk deel van een formule apart door te rekenen en zo de plaats van de fout langzaam steeds nader te bepalen. De techniek zal hier aan de hand van een voorbeeld worden gedemonstreerd. Voer in een leeg werkblad de volgende berekening in, die afhankelijk van de grootte van een bedrag een korting berekent (5% van de waarde indien deze groter is dan 50.000, anders 3%):

A1 Bedrag:
B1 50.000
A2 Korting:
B2 =ALS(B1>50000;B1>0,05;B100,03)

Voer vervolgens in cel B1 een tekst in, bijvoorbeeld geen bedrag. De formulecel B2 reageert daarop met de foutmelding #WAARDE!. Met behulp van deelberekeningen kunt u achterhalen aan welk deel van de formule deze fout te wijten is:

Stap voor stap
1 Selecteer cel B2. Selecteer vervolgens in de formulebalk het deel van de formule dat de voorwaarde voorstelt (B1>50000).
2 Druk op de functietoets F9.
3 De deelformule wordt berekend; het resultaat WAAR geeft aan dat aan de voorwaarde is voldaan. Druk op de Esc-toets.
4 Selecteer nu (opnieuw in de formulebalk) het tweede argument (B1*0,05) en druk weer op F9 (zie figuur 1). U hebt de fout nu gevonden, want deze berekening kan niet worden uitgevoerd.

Excel tips trucs | Financiele Professionals
Afb. 1: Deelberekening van de formule in de formulebalk

Vind je vaste baan

Al 28 jaar is WR het Werving en Selectie bureau voor vaste banen.